Database di supporto per Database di Azure per PostgreSQL- Flexible Server vaulted backup

È possibile usare Backup di Azure per proteggere il server flessibile di Database di Azure per PostgreSQL. Questo articolo riepiloga le aree supportate, gli scenari e le limitazioni.

Aree geografiche supportate

Backup con insieme di credenziali per PostgreSQL: il server flessibile è disponibile a livello generale in tutte le aree cloud pubbliche e le aree sovrane.

Note

Backup di Azure for PostgreSQL flexible server e elastic cluster (v2) sono ora in anteprima. La soluzione v2 prende backup fisici da snapshot gestiti del disco invece di backup logici (pg_dump basati), e affronta i limiti della soluzione generalmente disponibile descritta in questo articolo:

  • Protegge server flessibili e cluster elastici di Database di Azure per PostgreSQL, con supporto fino a 32 TB su SSD Premium v1 e fino a 64 TB su SSD Premium v2, rispetto al limite di 1 TB
  • Supporta i programmi di backup giornalieri con un obiettivo di punto di recupero (RPO) di un giorno e il Ripristino come Server direttamente su un server flessibile target o cluster elastico, rispetto ai backup settimanali e al Ripristino come File.

La soluzione descritta in questo articolo rimane generalmente disponibile. Per saperne di più sull'anteprima, consulta About Backup di Azure for PostgreSQL flexible server and elastic cluster (v2).

Scenari di supporto

Quando si esegue il backup di Database di Azure per PostgreSQL - Server flessibile, considerare gli scenari di supporto seguenti:

  • I ripristini di backup con insieme di credenziali sono disponibili solo come Ripristina nei file nei contenitori di archiviazione specificati dall'utente. È possibile ripristinare questi dati come nuovo server flessibile PostgreSQL con gli strumenti nativi del database.
  • I backup per il server PostgreSQL sono supportati quando l'insieme di credenziali di backup si trova nella stessa sottoscrizione o in una sottoscrizione diversa del database, purché si trovino nello stesso tenant e nella stessa area. I ripristini sono supportati tra aree (Abbinate di Azure) e tra sottoscrizioni all'interno dello stesso tenant.
  • Per i backup con insieme di credenziali, viene eseguito il backup dell'intero server con tutti i database. Il backup di database specifici non è supportato.
  • I backup con insieme di credenziali sono supportati per le dimensioni <del server = 1 TB. Se il backup è configurato con dimensioni del server superiori a 1 TB, l'operazione di backup ha esito negativo.
  • PostgreSQL: sono supportati i server flessibili crittografati dalla chiave gestita dal cliente.
  • I backup per i server flessibili PostgreSQL escludono i database di proprietà di azuresu o azure_pg_admin, incluso il database PostgreSQL nativo. I database con questi proprietari non possono quindi essere sottoposti a backup o ripristino.
  • La frequenza consigliata per le operazioni di ripristino è una volta al giorno. Più operazioni di ripristino attivate in un giorno possono non riuscire.

Limitazione

I backup del server flessibile di Database di Azure per PostgreSQL includono le limitazioni seguenti:

  • Il backup con insieme di credenziali non supporta l'archiviazione nel livello archivio.
  • Il backup con insieme di credenziali non è supportato nelle repliche; il backup può essere configurato solo nei server primari.
  • Il backup vaulted per cluster elastici non è supportato.
  • Il backup vaulted per server flessibili su memoria SSD Premium v2 non è supportato.
  • Per l'operazione di ripristino, il ripristino a livello di elemento (ripristino di database specifici) non è supportato.
  • Per i backup con insieme di credenziali, è attualmente supportato un solo backup settimanale. Se più backup vaulted vengono programmati in una settimana, viene eseguita solo la prima operazione di backup della settimana e i successivi lavori di backup nella stessa settimana falliscono.
  • I backup con insieme di credenziali non supportano tabelle contenenti una riga con lunghezza BYTEA superiore a 500 MB.
  • I backup con insieme di credenziali supportano solo backup completi; i backup incrementali o differenziali non sono supportati.

Limitazioni di ripristino

  • L'uso di creare script di ruolo per azure_su, azure_pg_admin, replication, localadmine Entra Admin causa gli errori seguenti durante il ripristino in un altro server flessibile, che è possibile ignorare in modo sicuro.

    • role "azure_pg_admin" already exists.
    • role "azuresu" already exists.
    • role "replication" already exists.
    • ERROR: must be superuser to create superusers
    • ERROR: Only roles with privileges of role "azuresu" may grant privileges as this role. permission denied granting privileges as role "azuresu"
    • ERROR: permission denied granting privileges as role "azuresu" SQL state: 42501 Detail: Only roles with privileges of role "azuresu" may grant privileges.
    • Ignore any errors related to pg_catalog, pg _aadauth extensions as it is owned by azure_su and localadmin does not have access to directly create this extension on flexible server, but these are automatically created on new flexible servers or when you enable Microsoft entra authentication.
    • ERROR: Only roles with the ADMIN option on role "pg_use_reserved_connections" may grant this role. permission denied to grant role "pg_use_reserved_connections"
    • ERROR: permission denied to grant role "pg_use_reserved_connections" SQL state: 42501 Detail: Only roles with the ADMIN option on role "pg_use_reserved_connections" may grant this role.
  • In PostgreSQL community versione 16 è stato rimosso il requisito per i privilegi con privilegi avanzati per impostare l'attributo Bypass Row -level security (RLS). Pertanto, nelle versioni 16 e successive, è possibile concedere la sicurezza a livello di riga di bypass a azure_pg_admin consentendo ad altri utenti di impostare la sicurezza a livello di riga. Per le versioni inferiori a 16, l'attributo bypass viene concesso solo all'amministratore del server e non ad altri ruoli non di utente.

  • Se usi Entra Admins dopo il ripristino, potresti riscontrare il problema di modifica del proprietario : come soluzione alternativa, usa l'opzione grant per fornire la proprietà.

Passaggi successivi